[Logo] GDE Forum - Home for the best in diesel powertrain tuning
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Members] Member Listing   [Groups] Back to home page 
[Register] Register /  [Login] Login 
2007 wk crd p0404 and limp mode  RSS feed
Forum Index » New Mopar Torque Converter
Author Message
tcbrady

Joined: 10/04/2017 17:09:20
Messages: 2
Location: Portland OR
Offline
My jeep has been acting up alot lately. Last week i replaced the turbo actuator. This week its in limp mode again but this time its throwing codes related to the EGR p0404 primarily. The confusing part is I'm already running a GDE tune (EGR deleted) and I've physically blocked it off. Aside from being in limp mode and throwing the codes it seems to be running pretty bad, sputtering and smoking alot. Has anyone encountered this problem before? I've got a couple theory's of what it could be. because its throwing EGR codes i'm thinking it could be the throttle body. since it seems to be having trouble with the fuel mix it makes me think O2 sensor or MAF sensor.
Thanks in advance for any input.

07 Jeep Grand Cherokee CRD 170k miles.
tcbrady

Joined: 10/04/2017 17:09:20
Messages: 2
Location: Portland OR
Offline
Update: I tested the throttle body. that made no difference. i cleared the codes. the only one that persisted was p0403. Ic also unplugged the maf that generated some different codes.

07 Jeep Grand Cherokee CRD 170k miles.
BC-X

Joined: 19/10/2017 02:17:05
Messages: 1
Offline
Did you ever resolve this issue?
 
Forum Index » New Mopar Torque Converter
Go to:   
Powered by JForum 2.4.1 © 2015 JForum Team • Maintained by Andowson.com